I am trying to connect MySQL Workbench to our K1000. I have read the information I have found at the following sites:





I made sure the port was open and that the services are running. I have confirmed the password is correct for r1 and we only have one organization.


I have uninstalled and reinstalled MySQL Workbench. Nothing works. I have also seen various other posts on other sites relating to problems not being able to connect various databases to MySQL. Nothing I can find is helping me get any closer to an answer.


From what I am reading, it appears that the only thing I need to do on the KACE side is to check the enable database access boxes, which I have done.


I have tried to connect with the ODBC settings and the MySQL Workbench – both failed to connect.


My end goal is to see the tables in the database so I can create rules to copy device information from the inventory to the asset tables. I can’t figure out a way to get this done without access to the tables so that I can make sure the names are correct. Are there any other programs besides MySQL that I can try?


I know this is asking a lot but I am running into dead ends. Any assistance would be gratefully accepted.

Answer Summary:
3 Comments   [ - ] Hide Comments


  • I use toad, but Mysql workbench should work fine.

    Also, if you are using version 8, check this URL:

    If you are 100% sure about the port being open then contact Tech support
    • Thank you. We started using 8.0 so there was no upgrade that could have interfered with database access. I have submitted a ticket with Quest in the hopes that they can help me.
      • Let us know the outcome
      • They confirmed the settings in KACE and MySQL Workbench is correct. However, I still cannot connect. My progress is effectively stalled until this can be resolved.
  • Try HeidiSQL. It uses it's own session manager rather than an ODBC connector
    • I just downloaded it to give it a try. Frustratingly, I am getting the same error with HeidiSQL. It cannot connect either.
  • Did you capitalize R1 and ORG1?
    • I did not but when KACE Support remoted in, he corrected it. However, it still will not connect.
Please log in to comment

Answer Chosen by the Author


I can't provide any information has to how this problem was corrected but Quest Support restored access.
Answered 01/09/2018 by: jessburd
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity


On mine it was the kb referenced earlier. I had to enable secure database access, generate the key and then disable secure database access. Then accessing it via username / password worked again.
Answered 01/03/2018 by: five.
Second Degree Blue Belt

  • We have only had 8.0. So if I understand the information correctly, this would not apply to use. When I go to the Logs and check update, there are no logs since we have never applied an update. Just to over my bases, I have activated the secure database access and generated the key, but it has made no difference whether it is active or not as it has been tried both ways multiple time.
    • Could it be a client firewall or antivirus issue? Have you tried from multiple machines? You could try adding a firewall rule or temporarily disabling firewall.
      • I turned off the firewall on my computer and allowed the port on the server. I also temporarily disabled our protection software. None of these actions made a difference.
Please log in to comment