/build/static/layout/Breadcrumb_cap_w.png

K1000 Inventory Location vs Asset Location

If you are struggling with the new Location and Assigned users fields within Inventory, or if you are looking at implementing Asset Management Best Practice (BSI 55000/ ISO 55001) and Barcode scanning then you may find this blog helpful.

So with the introduction of the Barcode scanning capability in the Go App, came a number of table changes that reflect within the Inventory records of Devices.

The functionality of the Barcode scanner GoApp, for those of you who have not yet investigated, basically distils down to the following:

- Scan a single Asset (Device)
- Update a single Asset (Device)
- Associate a barcode with an Asset (Device)
- Associate a location with an Asset (Device)
- Associate a User with an Asset (Device)

When associating an Asset with a user or a location that data is now shown within the summary area of the inventory record, as well as within the Asset record.

y6DzxL.jpeg                                 lD3qae.jpeg

What KACE have also helpfully done, is rewrite the standard Asset and Inventory listing views, so that they now default to the new values. Therefore if you have been associating a location with an Asset, using the traditional method of adding the Asset Location field into the Asset type, then it may look as if all your data has disappeared.

Zmew55.jpeg

You can find your Asset Location data by clicking the blue cog and selecting the correct fields to display, but you would need to do that for every tech that logs on ......

As a workaround for customers using the Asset Location as their location fields and in particular our own BarKode customers, we have created the following workaround that we hope will be of help.

If we refer to the location shown in Inventory as the "Inventory Location" and
if we refer to the location shown in the Asset as the "Asset Location" the instructions below will allow customers using primarily the Asset Location for their location value, to duplicate the value into the Inventory location, so that the two locations synchronise. 

The benefit of this is that regardless of what location value you then select on an asset list or inventory list view, it should be the one set by your Asset Management best practice.

To do this we will use a Service desk ticket rule.

First we need to make sure that at least one device in our inventory has an Asset location value set as well as an Inventory Location value set. Choose any asset and within the Asset record add a value to both data fields, but make them different values, then save the asset record.

Next we must establish which data field within our Device Asset contains the Asset Location ID. To find this out, run the following SQL as a report on your K1000.

Select
  ASSET.ASSET_DATA_ID,
  ASSET.NAME,
  ASSET_ASSOCIATION.ASSET_FIELD_ID,
  ASSET.LOCATION_ID,
  ASSET_ASSOCIATION.ASSOCIATED_ASSET_ID,
  ASSET_FIELD_DEFINITION.FIELD_NAME,
  ASSET.ID,
  ASSET.ASSET_TYPE_ID
From
  ASSET Inner Join
  ASSET_ASSOCIATION
    On ASSET.ID = ASSET_ASSOCIATION.ASSET_ID Inner Join
  ASSET_FIELD_DEFINITION
    On ASSET_ASSOCIATION.ASSET_FIELD_ID = ASSET_FIELD_DEFINITION.ID
Where
  ASSET.ASSET_TYPE_ID = '5'

The resulting report will look like the following image

2u3HiG.jpeg

Note the highlighted line shows a location value (column 7) and an Asset ID of 5 (column 9) i.e. a Device; on any line showing these details we can see the Asset Data field reference, in this case 10041. Make a note of the number shown on your report.

Next we will create the ticket rule that will take the Asset Location Value and Synchronise the ID into the Inventory location field

In your K1000 go to ServiceDesk > Configuration - Rules and create a new (SQL) ticket rule in any available queue.

Give the rule a suitable name and description.

Paste the following SQL code into the Select Statement box:

Select
  ASSET.ASSET_DATA_ID,
  ASSET.NAME,
  ASSET_ASSOCIATION.ASSET_FIELD_ID,
  ASSET.LOCATION_ID,
  ASSET_ASSOCIATION.ASSOCIATED_ASSET_ID
From
  ASSET Inner Join
  ASSET_ASSOCIATION
    On ASSET.ID = ASSET_ASSOCIATION.ASSET_ID
Where
  ASSET_ASSOCIATION.ASSET_FIELD_ID = '10041'

Then update the number in yellow with the number taken from your earlier report.

Now paste the following text into the update statement box:

update
ASSET Inner Join ASSET_ASSOCIATION On ASSET.ID = ASSET_ASSOCIATION.ASSET_ID
set
ASSET.LOCATION_ID = ASSET_ASSOCIATION.ASSOCIATED_ASSET_ID
Where
  ASSET_ASSOCIATION.ASSET_FIELD_ID = '10041'

And again update the number highlighted in yellow with the same value taken from your earlier report.

Save the ticket rule and use the Run Now button to run the rule.

If there are no errors, the rule should have at least updated a single record, the asset you set the values for earlier in this process.

If you now check that asset record, the Asset Location value should be replicated into the Inventory Location field.

Now set your ticket rule to run every day or every hour and make sure the rule is enabled before saving.

If you would like to know more about Asset management Best Practice, how to use your KACE box to become ISO 55001 compliant or how you can cut your losses and save money by using our feature rich BarKode scanning product then feel free to contact us:

e: theindigoteam@indigomountain.co.uk
w: www.IndigoMountain.co.uk

Comments

  • Hello,

    Thanks for your post.

    I was interested by doing this as all my Asset location field where updated manually the first time we did our inventory and it could be good to have the same value in the new "inventory location" field.

    I followed your instruction but it seem nothing happen when I run the Ticket rule.

    There is no error but the returned log is:

    03/30/2017 15:57:23> Starting: 03/30/2017 15:57:23 03/30/2017 15:57:23> Executing Select Query... 03/30/2017 15:57:23> selected 0 rows

    The fields didn't sync and are still different.

    When I go into -> Assets -> Locations I see the Assets Unique ID is correctly the one that your report gave me (for you 10041).

    Any idea of what could prevent this to work ?

    Also my knowledge in SQL is pretty basic so I try to tweak around with what I find on itninja.

    Thanks in advance - YunolikeSQL 4 years ago
    • Make sure that you have at least one inventory Item with an Inventory location and an Asset location set - Hobbsy 4 years ago
      • Hello again,

        My "old" location field is a field we created to be set for each material asset (required). It's a drop down list linked to another Asset type called "locations" where we created the few locations choices. For the test I set it to a value "A" on a specific asset.

        Now with the new updated I still have this field for each "material assets" but also a new one called "locations" that doesn't appear in the asset type column list (so we cannot make it required), and the choice of value in it were corresponding to the drop down list. I assumed it was this new "inventory location". and I set it to a value "B" for the test.

        Previously. when I was searching for an Asset name in Kace, the result was showing the column I wanted including my "home-made" location field and other details, now it show a lot less column and I don't have the choice to display my home made location field but only the new one "B".

        When I search for this asset name in the Inventory part under Devices" the column display the same location field (with value "B"), if I right click to choose to display more column, I can find another column called "Assignee location" that is "unassigned" but I assume this is not the field we are looking for and a last "location" column that I assume should be my home made field. The strange thing is that this column is empty (not containing the value "A"), if I click on this column as for "order by" I receive an error message:

        There was an error retrieving the data for this page.
        Please refresh the page. If the error persists, try resetting the default page layout.

        There is certainly something wrong that I missed, but first thing first, is my conception of the "Asset location field" and "inventory location field" correct? Maybe I'm mistaken the field we were talking about but as this field only appeared recently with the update I assume it was the one you were talking about.

        Thanks again for your kind help - YunolikeSQL 4 years ago
  • email me and let's jump on a quick call.... - Hobbsy 4 years ago
This post is locked
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ