/build/static/layout/Breadcrumb_cap_w.png
04/12/2017 12700 views
I have Adobe acrobat DC Pro (15.006.30033 version) package already created. But, the PDF maker add in does not show in Outlook 2016 Add-in tab. 
It is in 'Inactive' state when I checked in Files->options->Add-in

How do I make this 'active' so that it is visible in the Add-in tab?

I went through many solutions as below: 

1.       Enable the Acrobat PDFMaker Add-in

  • Open Outlook 2016 and click File > Options > Add-ins.

  • Select COM Add-ins next to Manage and click Go.

  • In the list of available add-ins, find the Acrobat PDFMaker COM Add-in and check if it's enabled. If it isn't, check the box to enable it.-> here, when I check the box, after restart of Outlook, it will be unchecked. That is, it doesn’t allow me to ‘enable’ it.

       2. Disable and Enable the Acrobat PDFMaker Add-in

  • Open Outlook 2016 and click File > Options > Add-ins.

  • Select COM Add-ins next to Manage and click Go.

  • In the list of available add-ins, find the Acrobat PDFMaker COM Add-in and check if it's enabled. If it is, uncheck the box to disable it.--> It is already disabled (unchecked). 

  • Close and reopen the Office 2016 application.
  • Go back to COM Add-ins, enable the Acrobat PDFMaker add-in, then click OK.

    --> I checked but nothing happened. Nothing happened even on restart of Outlook.

2.       Remove and reinstall the Acrobat PDFMaker Add-in

  • Find Outlook 2016, right-click it, and click Run as administrator.

  • Open a blank new file.

  • Click File > Options > Add-ins.

  • Select COM Add-ins next to Manage and click Go.

  • Select the Acrobat PDFMaker COM Add-in and click Remove.--> I removed successfully.

  • Click Add and navigate to C:\Program Files (x86)\Adobe\Acrobat 2015\PDFMaker\Office\PDFMOfficeAddin.dll.--> Added as specified.

  • Close and restart the Office 2016 application.--> when I am restarting the Outlook 2016, the addin does not show even in ‘inactive’ column. That is, it does not allow me to reinstall the addin.

3.       Change the registry key HKLM

  • Go to Start and search "Run". You can also press on the Windows Key + R to bring up the Run window.

  • In the Run window, type "regedit".

  • Find this registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin.

  • Change the Loadbehavior key value to 3. (decimal)à It is already set as specified.

  • Exit the registry key editor and restart the Office 2016 application.--> when I restart, the add-in still won’t appear in the tab.

4.       Register the DLL

·         I tried registering the Add-in dll file manually.

·         Locate the COM add-in file (PDFMOfficeAddin.dll) and note the exact path, which may include spaces.

·         Open the cmd->run as admin.

  • Type regsvr32 followed by a space, and then type the path that you noted in previous step, in quotation marks. For example: regsvr32 "C:\Program Files\Adobe\Acrobat 10.0\PDFMaker\Office\ PDFMOfficeAddin.dll "

  • Click OK, and then start the Office application.--> when I restart outlook, still the add-in does not show as active.

5.       Change the registry key HKCU

·         The similar registry, as in point 3, was found in HKCU too: HKCU\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin.

·         Initially, when I try to change its load behavior as 3, it gets changed. But, after opening the Outlook 2016, it is again set to value 2. Thus, it is editing it in run time. So, this method also fails.

This last step may be the huddle due to which it is not activating it. Since the value keeps on changing during the run time. I found this particular step in various websites stating that load behavior should be 3 so that when we restart Outlook from step 1, the add-in is active and enabled and does not get disabled henceforth.


Please suggest. 

5 Comments   [ + ] Show comments

Comments

  • Maybe there's a security setting in Outlook itself that is auto-disabling it? I know that the Office Customization Wizard allows you to set policies for add-ins, so maybe that's part of your Office deployment? Just a guess.
  • Okay! That was new to me. Thanks for the info.

    It got resolved. It was downloading a patch over internet by which the addin was coming. So, it just needed an update.
    I took that patch and packaged it separately.
  • Also to mention, the registry:

    HKCU\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin

    Its Loadbehavior key still needs to be 3 (decimal)
  • After applying the patch, its load behaviour is not changing itself as I had mentioned in the question.
  • Also, the below registries shouls also be present:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Acrobat PDFMaker\2015\Office\SupportedVer]
    "LowestSuppVer"=dword:0000000c
    "GreatestSuppVer"=dword:00000010


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Acrobat PDFMaker\2015\Outlook\SupportedVer]
    "LowestSuppVer"=dword:0000000c
    "GreatestSuppVer"=dword:00000010

All Answers

0

To help future readers - issue resolved due to incompatibility between Adobe Acrobat and Office versions.

Latest Adobe Acrobat 11 updated link

http://ardownload.adobe.com/pub/adobe/acrobat/win/11.x/11.0.23/misc/AcrobatUpd11023.msp


https://support.microsoft.com/en-au/help/2800094/incompatibilities-between-office-programs-and-adobe-acrobat-pdfmaker-o

Office versionSupported PDFMaker add-in versions
(check PDFMOfficeAddin.dll version)
2010 (32-bit)10.x and later
2010 (64-bit)10.1 and later
2013 (32-bit)11.0.1 and later
2013 (64-bit)11.0.1 and later
2016 (32-bit)11.0.16 and later
2016 (64-bit)11.0.16 and later
Answered 05/13/2019 by: phatbear
White Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share