/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


Appv package not working with normal user

05/05/2017 3372 views
I have an appv package created.
When I publish the package.
It is working with admin user but not working with normal user.
Even I tried giving permissions to all the folders but same issue.
I am getting below dll error.
But the dll is present in the folder where the exe is present.
pDL5jc.jpeg
1 Comment   [ + ] Show comment

Comments

  • When running as an admin user, if you have UAC enabled, does a UAC prompt appear? If not then the process won't be running with admin rights anyway, and your issue might just be down to the fact it is running under a different user rather than the fact they are an admin. Also are both accounts domain accounts?

All Answers

1
Does it work with standard user while installed natively (I mean the standard installation of the application and then launch it as a standard/restricted user - do not start it as an admin for the first time).
This error looks like an application specific error, so maybe you could find something in the vendor's documentation.
Have you checked "Allow all named objects...", "Allow all COM objects ...." and "Allow full write permissions..." in the Advanced tab? I would try with these 3 selected.
You have mentioned that DLL is present in the folder, but the error is not saying that the DLL is missing ;-)

If locally installed application works fine with a normal user then the only option  I see is the ProcMon....
Answered 05/08/2017 by: rad33k
Fourth Degree Brown Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ