/build/static/layout/Breadcrumb_cap_w.png

Systems Management Question


Auto Uninstall software based on label.... I need help troubleshooting...

07/18/2013 1742 views

This was a previously answered question, but there's something that I'm not following correctly....

Original question:  http://www.itninja.com/question/kace-auto-install-uninstall-software-based-on-label

 

MY PROBLEM:  I have been trying to set something like this up and I really like the idea of having 2 MI's, instead of using an uninstall script, like I have been.  


I'm having trouble getting the labels setup in this way for some reason.  When I test the Smart label (uninstall) I lose all machines when I add "AND software Titles contain".  

Here's exactly how I did it, so you may be able to point out the errors of my ways....

I already had the software (I'll call it Office Job Instructions) installed for the machines I needed so I created a label APP:  Office Job Instructions (with no restrictions) and applied it to the software item.  I then went to Computer Inventory > Advanced Search > Software Titles  =  Office Job Instructions and searched.  That resulted in a list of all machines with Office Job Instructions installed.  From there I selected all machines and applied the "APP:  Office Job Instructions" label to each one, essentially the same thing as manually adding computers to the label.  Then I created a managed install that would be used for the actual installs.  I then tried creating the label you mentioned above.  Machine Smart Label using "Label names != APP:  Office Job Instructions AND Software Titles contain      Office Job Instructions"  and created "REMOVE:  Office Job Instructions"

To test the new label I selected 5 machines (by putting a check mark next to the machine name) and removed/un-applied the "APP:  Office Job Instructions" label and forced check-in on the 5 machines.  

Besides being removed from the original label there was no change, none of them moved into the REMOVE label.  

I've used my powers of trial and error to make changes and test, but have been unsuccessful....  It's very disappointing and I would appreciate any and all help or advice in this matter.

Thank in advance and sorry for writing so much!!!

0 Comments   [ + ] Show comments

Comments


Be the first to answer this question

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ