/build/static/layout/Breadcrumb_cap_w.png

Scripting Question


Automatically Reboot Server Gracefully after Patch

10/15/2014 2815 views
Due to the number of servers we have, we've designated some to be able to reboot automatically after being patched by Kace.   It seems like whenever the Kace appliance reboots one of these servers we get the 'Shutdown Event Tracker' asking 'Why did the computer shut down unexpectedly?'  

Is there a way to add graceful switches to this process so the reboot doesn't generate these messages?  
Answer Summary:
0 Comments   [ + ] Show comments

Comments


All Answers

1
I would disable the Shutdown Event Tracker completely.
Never seen additional use in this tracking. It is a good functionality if you need this info.

Disabling it via 
reg add "\\\HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Reliability" /v ShutdownReasonOn /t REG_DWORD /d 
should be fine. This can be scripted with the K1000.
Alt. if you don't want to disable it, set the reboot option to no reboot and reboot by hand or via script (shutdown -r -t 90  -dp 08:15 Regular reboot due to patching )
This will reboot the system after 90seconds an enters the cause Regular reboot due to patching with ID 08:15 into the event tracker automaticly.

Currently there is no possibility to set this in the patching cycle.
I suggest you to go to kace.uservoice.com and vote for this, then it may come in the future.
Answered 10/16/2014 by: Nico_K
Red Belt

  • Thanks Nico_K. I was actually hoping to keep the shutdown event tracker, but I can't really think of a good argument for it, so I guess you win. This will be our route.
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ