Disable JRE 17-U40 update prompt

I'm having an issue in Win7 where a dialog box comes up and says that my Java version is out of date. Can someone please tell me how to disable this or is this a known issue? I also have the following added to my Registry & deployment.properties





0 Comments   [ + ] Show comments

Answers (2)

Answer Summary:
Posted by: rockhead44 7 years ago
Red Belt

Add a deployment.properties and deployment.config file to C:\Windows\Sun\Java\Deployment\

Modify the properties file to set the value deployment.expiration.check.enabled=false from true

That will suppress the expiration message that you are seeing (even though Update 40 is not expired). We started seeing the same message once 45 was released Tuesday. Even with that registry key changed from 1 to 0 to suppress updates, as you did, the expiration date is coded into Java.

You can find information about those 2 files at http://docs.oracle.com/javase/7/docs/technotes/guides/deployment/deployment-guide/properties.html

  • That page no longer exsists. Any updates with j7 u55? - rsm11 6 years ago
  • Also appears I don't have the c:\windows\sun\java\directory - rsm11 6 years ago
    • Create a directory & also create two files. One named deployment.config with the following content "deployment.system.config=file\:C\:/WINDOWS/Sun/Java/Deployment/deployment.properties " and deployment.properties with the following content deployment.javaws.autodownload=NEVER
      deployment.expiration.check.enabled=false - chichora123 6 years ago
Posted by: chichora123 7 years ago
Fourth Degree Green Belt

This worked for me & i really appreciate for your help.

This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ