/build/static/layout/Breadcrumb_cap_w.png

Failing to boot to the x64 KBE with an E6420

Gentlemen,

Regarding the above title, I have just recently began setting up and testing our K2100 to ready it to be used regularly in our deployments.  I built two enviroments, an x86 and x64 and tested the x86 enviroment on a old Latitude D630, which worked fine.

I'm now trying to do the same with a x64 enviroment on a E6420, however I'm getting several problems:

ERROR: Unable to determine server IP address from DHCP

ERROR: Unable to mount K2000 share at \\xxx.xxx.xxx.xxx\peinst

Doing an ipconfig, I confirm that I'm not getting an IP address.  And due to the fact the D630 worked without a hitch I'm assuming it's not a DHCP issue.  Doing some research I noticed someone had the same problem with a E6410 and reported that removing the default driver from the drivers\kbe_windows_x64\kace directory and adding in the one he downloaded solved the issue.

I've attempted to do the same, adding the FOLDER to the root kbe_windows_x64 directory, then recaching and rebuilding the KBE only to meet failure.  Then doing the same as above only adding it to the kbe_windows_x64\kace directory, recaching and rebuilding only for it to fail again.  Is adding the folder incorrect? Should I be placing the .inf / .sys files directly into the directory?

Any help would be great.  I have updated the box to the newest available version before any of this began.


Thank you in advance.


0 Comments   [ + ] Show comments

Answers (5)

Answer Summary:
Posted by: cserrins 9 years ago
Red Belt
3

Can you try our new driverpack?

http://downloads.kace.com/support/downloads/drivers/KBE_driver_pack-a08-r_k-arvy.zip

 

Remove the old drivers from kbe_windows_xXX, then add the ones included in the appropriate locations.  Recache the drivers for the k2 boot environment and then build a new kbe.

 

Let us know please.

Thanks,

Corey
Lead L3 Enterprise Solutions Engineer, K2000
If my response was helpful, please rate it!


Comments:
  • Hi Corey, Ive ensured the correct drivers are in the kbe_windows_x86 folder but no matter what it returns almost immediately to the systems deployment menu. Ive tried drivers from the updated driverpack, direct from the dell website and also the dell cab download for the e6420. Very frustrating as I need to roll out 10 of these in next few days. Any suggestions appreciated... - paddyl 9 years ago
Posted by: dugullett 9 years ago
Red Belt
1

Have you tried using the Driver Harvesting utility? This will do a lot of the work for you. http://k2000name/driver_harvesting_utility

Are you extracting the drivers package, or just copying the exe to the folder? 

 

Posted by: philologist 9 years ago
Red Belt
1

Also check your BIOS version.  This does sound like a driver issue, but the E6420 BIOS has had several problems along the way with PXE and network settings.  It won't hurt to check whether the BIOS might be causing issues.

Posted by: LN13 9 years ago
Senior White Belt
1

I had the same issue with the E6420.  It would PXE boot to the K2100 and present the KBE selection menu, start loading a KBE, then bounce back to the menu.  I loaded the latest driver pack, recached and created a new KBE, without any luck.  then I emailed KACE support.

The A13 BIOS on the E6420 has known PXE boot issues.  The solution is to downgrade your BIOS to A12.  I did it, and it worked like a charm.

The A12 BIOS:
http://www.dell.com/support/drivers/us/en/RC979033/DriverDetails/Product/latitude-e6420?driverId=G56MN&fileId=2981940090

 

Posted by: paddyl 9 years ago
Orange Belt
0

No joy so far with getting the E6420 to boot from the KBOX2100. All other Dell models work fine.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ