/build/static/layout/Breadcrumb_cap_w.png

Firefox 18 deployment issues - config problems

I'm trying to deploy Firefox 18.0.1 and as always the usual command -ms works great, but what doesn't work anymore, is configuring of the browser, so the users get similar configuration.

I have this file local-settings.js in C:\Program Files\Mozilla Firefox\defaults\pref

pref(“general.config.obscure_value”, 0);
pref(“general.config.filename”, “mozilla.cfg”);

This file tells Firefox where to get it configuration from, in this case mozilla.cfg

So I have mozilla.cfg in C:\Program Files\Mozilla Firefox, which contains:

//Firefox Default Settings

pref(“browser.startup.homepage”,”http://www.youtube.com”);
pref(“browser.startup.homepage_override.mstone”, “ignore”);

//disable default browser check
pref(“browser.shell.checkDefaultBrowser”, false);

// Disables ‘Know your rights’ message on first launch
pref(“browser.rights.3.shown”, "true");

But it doesn't work, it should work, as it's the "official" way to use custom config in Firefox, but my cfg file is simply ignored and I have no idea why.

I also have override.ini in C:\Program Files\Mozilla Firefox, so it doesn't run import settings guide

[XRE]
EnableProfileMigrator=false

Any ideas and own expirence with Firefox 18 and these config files would be great, thank guys.


0 Comments   [ + ] Show comments

Answers (4)

Posted by: jaybee96 8 years ago
Red Belt
1

Found this info, not sure if it helps.. 
mozilla.cfg has to be placed in the Firefox installation directory, and local-settings.js inside installation directory\defaults\pref. 


Comments:
  • Thanks, That is also what I'm doing, but doesn't seem to work. Might be a bug in Firefox, I would just like it to be confirmed from other who deploys Firefox :) - Erroneus 8 years ago
Posted by: flabdablet 8 years ago
White Belt
0

The right place to put your local-settings.js has changed: see http://mike.kaply.com/2012/08/01/major-change-setting-default-preferences-for-firefox-14/

Posted by: EbrithilBowser 8 years ago
Fourth Degree Green Belt
0

override.ini has to be set in INSTALLATION DIRECTORY\browser\ since Version 21 or so

Posted by: Rvlieburg 8 years ago
Third Degree Blue Belt
0

First force the users to use the same profile path which is defined in %APPDATA%\Mozilla\Firefox\profiles.ini  :

[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=1
Path=Profiles/firefox.default

Then copy a default user.js file to the folder %APPDATA%\Mozilla\Firefox\Profiles\firefox.default  with e.g. the following content:

# Mozilla User Preferences

/* Do not edit this file.
 *
 * If you make changes to this file while the application is running,
 * the changes will be overwritten when the application exits.
 *
 * To make a manual change to preferences, you can visit the URL about:config
 */

user_pref("app.update.enabled", false);
user_pref("app.update.service.enabled", false);
user_pref("browser.search.update", false);
user_pref("browser.shell.checkDefaultBrowser", false);

 

 

 

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ