/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Currently my environment does not have pxe boot. As a workaround I've been using USB for new machines and the K1 to push out something Corey posted a few years ago on a KKE. A whitepaper called Imaging Windows Tablets and Other UEFI Systems over the Network with KACE was also published. This works fine when a display is connected, but if the computer is headless, it doesn't seem to work. VNC doesn't work and hooking up a monitor after the fact doesn't do anything. The hard drive led does blink so it's doing something, I just can't get in to choose the proper deployment.

I think my two options are:

  1. Go a step further and actually make a KBE with the command line options built in that automatically choose a deployment and go. Since I am not able to remote in and choose one. I think that's covered in the video. Command listed below.
  2. Buy one of those headless hdmi adapters.
The command listed in the video is: 
start /wait y:\scripts\system_image_id#.bat

Any other thoughts on a solution to this problem?

3 Comments   [ - ] Hide Comments

Comments

  • We use UltraVNC with headless towers desktops, you would need to check for ports.

    (we basically turn on the headless tower, then arrow down enter to pick the default KBE, we wait 3 minutes, and then with VNC we remote in).

    VNC will ask for a password ASAP after clicking on "Connect", if it's not, then is a port issue.

    I am using K2 version 4.1
    • And you're doing the same thing, where you push it out and it reboots into the KBE? Or using PXE? I had no luck with option 1, where you create custom KBE's. The KBE works fine, just not headless. Not sure what you mean by check ports. Not in windows, so no firewall to check. Unless you mean the routers/switches. In which case, I don't have much access to that.
      • Yes, VNC ports can be blocked in network level (that means it does not matter if you are in windows or not... Now, KBEs use Windows PE, so in the end is still windows, we had to request our network team to whitelist VNC ports for this, as soon as they did this, VNC worked).
  • Hmm. VNC works fine the rest of the time. So I'm not sure that's it. And in the past it's always been default port. Never had to change to some weird port just because it's KBE.
  • Just being logical, headless will not cause any harm to any software.

    Are you sure that we are properly loading that KBE in headless mode?

    Maybe create a new KBE with KBE Manipulator, and make sure that "Launch UltraVNC" is checked inside the Modify KBE options.
Please log in to comment

Answer this question or Comment on this question for clarity

Answers

0
After having some time to play around with this, it was not the headless part or the KBE part that was an issue. I had to modify the original batch file that loads the KBE. It was sporadic as to whether it would work or not. Usually worked the first time, but would fail after that. Added some checking and allowed overwrite on the copy. Also added the %~dp0 when grabbing the wim file. It seems pretty solid now.

The original script from the KKE and whitepaper:
mkdir c:\programdata\dell\kace\kbe
start /wait xcopy c:\programdata\dell\kace\kbe
ReAgentC.exe /disable
ReAgentC.exe /SetReImage /Path c:\programdata\dell\kace\kbe /Target c:\windows
ReAgentC.exe /enable
ReAgentC.exe /boottoRE
shutdown /r /f /t 0

My modified script:
IF NOT EXIST c:\programdata\dell\kace\kbe mkdir c:\programdata\dell\kace\kbe
start /wait xcopy /y %~dp0winre.wim c:\programdata\dell\kace\kbe
ReAgentC.exe /disable
ReAgentC.exe /SetReImage /Path c:\programdata\dell\kace\kbe /Target c:\windows
ReAgentC.exe /enable
ReAgentC.exe /boottoRE
shutdown /r /f /t 0
Answered 08/30/2017 by: five.
Green Belt

Please log in to comment

Share