/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


I have some dialog difficulties with an MSI using InstallShield

05/30/2012 4181 views

I have build the dialogs for my Installshield Basic MSI project from scratch but I seem to be expericing some odd behaviour when I test them, I'm sure there will be more issues than just this one but the first I come across is on the customer info dialog which prompts for name, company name and email and passes them into public properties with appropriate names.  However when I fill in the customer name field and tab down, the dialog fills the customer name into the other two fields too.  I am using Indirect properties as in some cases the user settings will already be in the properties via a custom action which interrogates legacy ini files, help!

Okay, I've tried deleting the Edit boxes and recreating them and now the companyname one no longer populates from the username but the email one still does from what was typed into the companyname property.

Answer Summary:
0 Comments   [ + ] Show comments

Comments


All Answers

0

I figured it out, for some reason setting the value for email and company in the property table was causing the UI to get confused so I instead created a unique string for the value of both properties and it no longer populates automatically.

Answered 05/31/2012 by: shields_t
Senior Purple Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ