/build/static/layout/Breadcrumb_cap_w.png
06/17/2019 102 views

Hi guys,


I'm having trouble with the metering option.

I have a 300 computer managed with some user having Visio installed on it. As I'm using Kace to reduce cost of unused license, I activated the metering on Visio, and applied a label for metering on each computer where it's installed.

I thought that it was working, and users were not using it, but, I just saw an user working on it, and after a quick check on Kace, it's not counted as used.

My Visio still shows 0 utilisation for the last days.

I updated the inventory of the computer concerned, same issue.

On my label I checked the following option :

Device inventory -> Meter software usage

Resources

Software

Catalog.

I created a new label and didn't use the one named MeteredDvices which was created by default.


Did I make a mistake somewhere that looks obvious to you ?

0 Comments   [ + ] Show comments

Comments


All Answers

1

The best way to verify that your labels are correct is to look in the Inventory Devices and Software Catalog and verify that the computers and software titles have the metering icon. You may also need to check how often metering data is uploaded. Browse to Settings › Provisioning › Communication Settings and check the values for Catalog and Metering. The metering data isn't updated in real time, so keep that in mind. 

You may also want to verify that the KSWMeterSvc.exe is running on the target device.

Answered 06/18/2019 by: chucksteel
Red Belt

  • Thanks for your answer Chucksteel,
    I checked and, in the software catalog, My Visio entry has the metered icon, when you open it, you have the metered checkbox checked, same thing for the computer where it's installed. I clicked on the installed number displayed in the visio entry and applied my metering label.

    Thing incredible, a person has been recorded as using Visio, but not the same person that I saw.

    Can I check somewhere else ?
    • Did you check the computer to verify that the metering service is running?
      • Hi Chuck,

        Sorry about the delay. I checked if the metering service is running on the computer, and it appears as running on each computer.
        I even tried it on my computer. I installed Visio, added the label to my computer and launched it. After few hours and several inventory, manual and automatic, my computer still didn't appears in the metered computer using Visio. It's quite troublesome.
  • Did you Browse to Settings › Provisioning › Communication Settings and check the values for Catalog and Metering. What are those settings?

    Have you tried metering any other software?
    • Hi Chuck,

      In settings -> Provisioning -> communication settings I have the following parameters : catalog = 12hours / metering =2hours.

      I enabled metering on Microsoft Project and I face the same issue.

      Can the trouble come from a blocked port on my firewall ?
      • The data is uploaded with the same method as inventory data, so I don't think it would be a firewall issue.

        On the machine, check c:\ProgramData\Quest\KACE\ and look for the metering_data.txt file. I'm pretty sure that is where it is stored on Windows. There may also be a KSWMeterSvc folder with more data inside.
    • I checked, I get the file with only 2 lines : 2019-07-04 07:32:13
      2,001
      I ensurred to launch Visio on my computer yesterday morning, and it has been working fine till today, still not counted on Kace. It's troublesome.
      • I checked multiple times and I still can't believe I have only 2 users who use Visio when few people around me are using it in front of me.
        It's bugging me.