/bundles/itninjaweb/img/Breadcrumb_cap_w.png
I am having a heck of a time getting our image installed onto a Surface Book 2. I am unable to PXE boot to the server as it errors out when it tries to Start PXE over IPv6. I have disabled IPv6 and it won't even attempt to PXE boot. I have created a USB KBE and can boot into KACE and go through the motions of installing the image, but when it has completed and restarts, it will boot back into KACE like I am installing the image again. I have also managed to boot into KACE with the KBE on one usb drive and the image on another, it will also install and then reboot back into the KBE to install the image again. 

I have created a support ticket with Quest and that has been of no help as well. Does anyone have any pointers to getting thisconfigured?
0 Comments   [ + ] Show comments

Comments


All Answers

1
iPXE is perfectly possible to Surface Devices.

Make sure your DHCP is configure for iPXE:
https://support.quest.com/kace-systems-deployment-appliance/kb/217556/dhcp-configuration-for-bios-and-uefi-pxe

Remember those Surfaces are UEFI devices, make sure your Image was captured from a UEFI source, and preferably, make sure you captured both C: and S: drives as per:
https://support.quest.com/kace-systems-deployment-appliance/kb/186950/uefi-image-process

Check your BIOS settings, if it's trying to do IPV6, that means it failed to do IPV4 for some reason, again check if your DHCP is working fine for UEFI devices, and check the Surface Manual, there are settings on the BIOS that might prevent UEFI PXE boot from working.
-Make sure secure boot is OFF
-I believe there is a settings Called UEFI network Stack, make sure is ON.
-We use the Surface Docking stations, no issues, haven't use those dongles:
https://www.amazon.com/Microsoft-Docking-Station-Surface-G5Y-00001/dp/B00N3J9QCS

Answered 03/27/2018 by: Channeler
Tenth Degree Black Belt

  • I have another Surface here that I have not messed with. When I go to capture an image from it, I do not see an S: drive.
    • You should not be capturing Images from physical Devices, build your golden Images and capture them from Virtual machines, see the Best Practices Article:
      https://support.quest.com/kace-systems-deployment-appliance/kb/121734/system-imaging-best-practices-for-windows

      Capturing OEM Images is against the Microsoft's EULA, see:
      https://support.quest.com/kace-systems-deployment-appliance/kb/135252/using-oem-source-media-and-images


      You could go to recovery, CMD, open DISKPART and assign the letter S to the small FAT32 volume.
      See:
      https://www.disk-partition.com/diskpart/assign-drive-letter-4125.html

      Then go back to the main Menu, and capture C an S.