Java 8 Deployement using MST - Disable AutoUpdate

Good morning,

I am having trouble deploying Java 8 Update 25.  I have successfully deployed Java 7 Update 25+ along with an MST file that disabled the Auto Update and the annoying prompt "Your Java Version is out of date.  Select Update, Block or Later"


I have followed the blog http://www.itninja.com/software/oracle/java-8/java-8-update-25 and I can see that some of the switch names have changed.  However after creating my MST, and test deployiong the app, I can see the necessary switches applyin in the registry but I am still prompted with the Java Version is out of date prompt.

I would like to upload my MST file, but it does not look like I have the option.  Has anyone successfully deployed Java 8 Update 25 using MST following the blog http://www.itninja.com/software/oracle/java-8/java-8-update-25 or would you recommend deplouyment using the java-install.cfg option?



0 Comments   [ + ] Show comments

Answers (2)

Posted by: anonymous_9363 7 years ago
Red Belt
Have you tried adding 'deployment.expiration.check.enabled=false' to the 'deployment.properties' file?

See here for details on that file, if you're unfamiliar with it.

  • I thought I read that entry was obsolete? OK.. let me make amends and strip Java from the test PC's and reapply....I'll let you know how I get on..Cheers! - Larrybk 7 years ago
  • adding that entry to the deployment file had no impact. However I decided to leave the Update tab enabled with teh latest install and I could see the Auto Update Check was enabled in the GUI. There must be another switch that I have missed in the MST and that may be missing off the other thread. I'll look into this further and I'll update this thread and the other if I find the switch that actually controls this setting. By disabling the check in the GUI Java control panel I am not prompted with the Java out of date message - Larrybk 7 years ago
Posted by: anonymous_9363 7 years ago
Red Belt
Odd...did you ensure that the deployment.properties file's companion file, deployment.config, points to the correct location? Did you use the global location or the user profile?

>not prompted
Maybe not now but you probably will be again when there's a new release. That's how this brain-dead policy works.

  • I have created an MST to deploy and supress the prompt.

    However, your addition of the line deployment.expiration.check.enabled=false in deployment.properties file IS a requirement

    I must not have stripped Java from the registry properly when I was reinstalling Java with your suggestion.

    At this time I am able to run Java applets with no prompt. I have checked Javasoft folder in the User and Machine registry and I cannot see and additional dword keys listed such as Frequency, NotifyDownload, NotifyInstall, UpdateSchedule. All of these keys create if you proceed to use Java after the "Your Java is out of date prompt"

    This is looking promising. Java 8 Update 25 is already expired with the secondary update mechanism ceasing in March 2015.

    However, I won't pass this off as a success until the latest version of Java (Java 8 Update 45) expires in July, then the secondary update check in August 2015. Although it is highly likely a new release of Java will be available before then!

    I'll report back after the next Java release and provide an update. I will also provide details of the MST changes I implemented, but it is pretty much everything that is indicated on the other thread http://www.itninja.com/software/oracle/java-8/java-8-update-25 including the addition of the line in the deployment.properties file - Larrybk 7 years ago
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ