/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


K2000- Copying a file using a "Application" Post-install task and calling xcopy command

10/28/2020 153 views

I am a new user of K2000 and one of the things I want to do during a system image deployment is copy a few .exe files locally to a folder, C:\kacetmp, using an "Application" Post-install task. I have attached the file to the "Application" task, E5410A16.exe and entered the following into the "Full command line" box: cmd.exe /c "xcopy E5410A16.exe C:\kacetmp /Y". During deployment, I get an error that reads something along the lines of "Unable to find the specified file". Is there a method to do this correctly?


0 Comments   [ + ] Show comments

Comments


All Answers

0

I tend to place the files and a batch file with the copy command in a zip file and then specify the batch file as the Full Command Line. I also take the extra steps of making sure the target directory exists first, etc.


Answered 10/29/2020 by: chucksteel
Red Belt

-1

the error is that it tries to run the (not uploaded) cmd.exe.

So you should use (if you have) the SMA to deploy the script which makes it easier or run a bat script.

Answered 10/29/2020 by: Nico_K
Red Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ