/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


VNC not working with K1000 on Win7 64bit

12/07/2012 6543 views

KACE 1000 box, VNC does not work on WIndows 7 64 bit IE8, getting error Unable to Run Machine Action but it will work on a Windows 7 32 bit machine.

I checked and it was set to the default path, I set it to the full path, it did not resolve and then it caused issues with the 32 bit machines that I use to remote on.  This was working on this machine but then was checking settings as another one of our techs needs to use it on a 64 bit windows 7 machine and he was getting the same error so I was testing to see if I could get it to work on his machine.  Now will not work on either and when I set it back to the default which is what it was set at, it won't work on my 64 bit machine, only the 32 bit machines.   Ideas???????

0 Comments   [ + ] Show comments

Comments



Community Chosen Answer

2

I think this article will really help you out with UVNC on KACE.

http://www.itninja.com/blog/view/using-the-kace-configuration-policy-to-install-the-ultra-vnc-client-in-5-4

Answered 12/07/2012 by: WhitzEnd
7th Degree Black Belt

All Answers

1

You need a separate machine action setting for 64-bit.  Check this out:

http://www.kace.com/support/resources/kb/article/How-to-set-Internet-Explorer-Security-Settings-for-use-with-the-KACE-K1000-Inventory

Note: When using Windows 7 64-bit and IE8 you must use the full path to the vncviewer.exe in the machine action settings.

Example:

"C:\\Program Files\\ultravnc\\vncviewer.exe" KACE_HOST_NAME

If you have it set to "%ProgramFiles%" it won't work on 64-bit machines.  You could configure the two machine action options for each one and just remember which one is 32 and which is 64-bit.

Answered 12/07/2012 by: nheyne
Red Belt

  • I added the second option, the 32 bit works with the default but when I set the full path the 64 bit still does not work.
    and it worked earlier today on my machine before I changed the settings from the default to the direct path on either 32 or 64 bit with the default, now the 32 bit is the only one that works with the default settings. 64 bit will still not do vnc remote,
0

Break it down step by sstep opt and paste the machine action path into an explorer window. Does it launch?

if not its a path problem. 

Here are only two requirements for vac to launch throu machine actions

1 vnc viewer exists in the path given

2 ie security settings allow the launch

 

Answered 12/08/2012 by: jdornan
Red Belt

0

Make sure your KBOX is in your trusted sites lists, via IP and via FQDN

Answered 12/10/2012 by: petelanglois
4th Degree Black Belt

  • "C:\Program Files\UltraVNC\vncviewer.exe" /dsmplugin SecureVNCPlugin64.dsm KACE_HOST_NAME

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ