/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


KACE scripts running on computer start-up, reboot script with warning

11/05/2014 4827 views

Hello All,

We just started using KACE as a major appliance at our group and I've been tasked with getting it up to speed so I'm very new at this. One of the first things we wanted to do was reboot all PCs running Dragon at 4am every morning with a warning for the user to abort should they be on the PC. So I wrote the following batch:

    @echo OFF >NUL
    TITLE Scheduled Nightly Reboot

    color E0

    c:\windows\system32\shutdown -r -f -t 90

    ECHO.
    ECHO.
    ECHO.
    ECHO YOUR PC IS SCHEDULED TO REBOOT IN 90 SECONDS AS PER POLICY!
    ECHO.
    ECHO PRESS ANY KEY TO ABORT REBOOT!

    PAUSE >NUL

    c:\windows\system32\shutdown -a

I have it running with the following settings:

    Deploy to label : Dragon Reboot List (All PCs with the Dragon Client)

    Scheduling:  Run Every day at 4:00

                         Allow Run While Disconnected

                         Allow Run While Logged Off

    Dependencies: Reboot Batch listed above

    Attempts: 1

 

The script works fine for all PCs that are up and running at 4am, the issue occurs at start-up for any PCs that were turned off; a number of them are running the script at start-up and rebooting first thing. When I did a run now to my PC of the script when it was off it did not reboot on start up, I got the error message in the log: "Script could not be pushed because machine was not connected." I'm not sure what is causing the discrepancies, I thought scripts would fail every time when pushed to an off machine. Any help would be greatly appreciated and thank you to anyone who took to the time to read this and assist.

    

Answer Summary:
0 Comments   [ + ] Show comments

Comments



Community Chosen Answer

1
You need to use the custom schedule to set a start/stop time for the script.  If you tell it to run at 4 and machines are off it is going to run when the systems are available.  See below:

Use an asterisk (*) to include the entire range of values in a field. For example, * in the minute column specifies minutes 0-59.
Use a slash (/) to repeat an action at specified intervals. For example, if you specify the following value in the hour field, 0-23/2, the action is performed every two hours. This has the same effect as writing out the hour values as 0,2,4,6,8,10,12,14,16,18,20,22.
Use an asterisk with a slash (*/) and a value to repeat an action at the specified interval. For example, */5 in the minute column repeats the action every 5 minutes. This has the same effect as 0/5 and 1-59/5.
Answered 11/05/2014 by: Ty
Senior White Belt

  • Thanks a lot for the reply, I wasn't familiar with this and the info you listed is terrific.

All Answers

0
Sounds like the script is being executed at start up as well.
Please verify registry or other locations.
Also verify if the script is set to reboot disregarding if it is passed it set time?
Answered 11/06/2014 by: dedenker
3rd Degree Black Belt

  • Thank you very much for the help

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ