/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Wondering if anybody has run into this and has any ideas for a fix. 

I use a K2000 for imaging, in particular we have a scripted install for Windows 10 Anniversary Edition. The setup is nothing special, we have the normal pre-install tasks (format the hard drive, etc.), the OS install from the ISO, and then various postinstall tasks (join the domain, etc.) that are done using an auto-logged in local admin. 

The problem I've run into is that lately, as soon as the local admin account logs in I get a "Your PC has an update waiting" screen that prevents any postinstall tasks from running 

 s7TloH.png

For the life of me I can't figure out a way to stop this from coming up, and it prevents any postinstall tasks from completing. Obviously I can click "Not Now" but I want to avoid the need for manual intervention. This happens before the PC joins the domain (that's a postinstall task) so I'm at a loss as to how to get around this. Any suggestions are appreciated. 
3 Comments   [ - ] Hide Comments

Comments

  • Never seen that one, but I bet is related to the answer file (the setup configuration).

    Do not enable Windows Updates to see if that helps.

    Also Did you build the answer file from the wizard, or you uploaded one on your own?

    Also check the OOBE settings on that answer file:
    https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/settings-for-automating-oobe

    Post your setup configuration here (answer file). (remove any sensitive data)/
  • Thanks! Here you go. There's one thing I did in there to see if the Task (which seems to be called UpdateAssistant) could be deleted, but that didn't work unfortunately.


    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <settings pass="windowsPE">
    <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="xxxxxxxxxxx" language="neutral" versionScope="nonSxS">
    <UseConfigurationSet>true</UseConfigurationSet>
    <UserData>
    <AcceptEula>true</AcceptEula>
    <FullName>xxxxxx</FullName>
    <Organization>xxxxxx</Organization>
    </UserData>
    <DynamicUpdate>
    <Enable>False</Enable>
    </DynamicUpdate>
    <ImageInstall>
    <OSImage>
    <InstallToAvailablePartition>true</InstallToAvailablePartition>
    </OSImage>
    </ImageInstall>
    </component>
    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="xxxxxxxxxxxxxx" language="neutral" versionScope="nonSxS">
    <UILanguage>en-US</UILanguage>
    <SetupUILanguage>
    <UILanguage>en-US</UILanguage>
    </SetupUILanguage>
    <InputLocale>en-us</InputLocale>
    <SystemLocale>en-us</SystemLocale>
    <UserLocale>en-us</UserLocale>
    </component>
    </settings>
    <settings pass="specialize">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="xxxxxxxxxxxxxxx" language="neutral" versionScope="nonSxS">
    <RegisteredOwner>xxxxxx</RegisteredOwner>
    <RegisteredOrganization>xxxxxx</RegisteredOrganization>
    <ProductKey>xxxxxxxxxxxxxxxx</ProductKey>
    <TimeZone>Eastern Standard Time</TimeZone>
    <ComputerName>*</ComputerName>
    </component>
    <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="xxxxxxxxxxx" language="neutral" versionScope="nonSxS">
    <Identification>
    <JoinWorkgroup>WORKGROUP</JoinWorkgroup>
    </Identification>
    </component>
    <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="xxxxxxxxxxxxx" language="neutral" versionScope="nonSxS">
    <RunSynchronous>
    <RunSynchronousCommand wcm:action="add">
    <Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>
    <Description>Setting Network Location</Description>
    <Order>1</Order>
    <WillReboot>OnRequest</WillReboot>
    </RunSynchronousCommand>
    <RunSynchronousCommand>
    <Path>SchTasks /Delete /TN \Microsoft\Windows\UpdateOrchestrator\UpdateAssistant</Path>
    <Order>2</Order>
    </RunSynchronousCommand>
    </RunSynchronous>
    </component>
    </settings>
    <settings pass="oobeSystem">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="xxxxxxxxxxxxxxx" language="neutral" versionScope="nonSxS">
    <OOBE>
    <HideEULAPage>true</HideEULAPage>
    <NetworkLocation>Work</NetworkLocation>
    <SkipMachineOOBE>true</SkipMachineOOBE>
    <SkipUserOOBE>true</SkipUserOOBE>
    <ProtectYourPC>3</ProtectYourPC>
    </OOBE>
    <UserAccounts>
    <LocalAccounts>
    <LocalAccount wcm:action="add">
    <Password>
    <Value>xxxxxxx</Value>
    <PlainText>true</PlainText>
    </Password>
    <DisplayName>xxxxxxxxx</DisplayName>
    <Group>Administrators</Group>
    <Name>xxxxxxx</Name>
    </LocalAccount>
    </LocalAccounts>
    </UserAccounts>
    <AutoLogon>
    <Password>
    <Value>xxxxxxxxx</Value>
    <PlainText>true</PlainText>
    </Password>
    <Enabled>true</Enabled>
    <LogonCount>5</LogonCount>
    <Username>xxxxxxxx</Username>
    </AutoLogon>
    </component>
    <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="xxxxxxxxxxxx" language="neutral" versionScope="nonSxS">
    <InputLocale>en-us</InputLocale>
    <SystemLocale>en-us</SystemLocale>
    <UILanguage>en-us</UILanguage>
    <UserLocale>en-us</UserLocale>
    </component>
    </settings>
    </unattend>
    • I see some lines missing.... Please create a new scripted install with the same source media (ISO), do not add any post install task, and use this as the answer file (setup configuration file):

      <?xml version="1.0" encoding="utf-8"?>
      <unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <settings pass="windowsPE">
      <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <UseConfigurationSet>true</UseConfigurationSet>
      <UserData>
      <AcceptEula>true</AcceptEula>
      <FullName>TestLab</FullName>
      <Organization>TestLab</Organization>
      <ProductKey>
      <Key>NPPR9-FWDCX-D2C8J-H872K-2YT43</Key>
      <WillShowUI>OnError</WillShowUI>
      </ProductKey>
      </UserData>
      <ImageInstall>
      <OSImage>
      <InstallToAvailablePartition>true</InstallToAvailablePartition>
      </OSImage>
      </ImageInstall>
      </component>
      <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <UILanguage>en-us</UILanguage>
      <SetupUILanguage>
      <UILanguage>en-us</UILanguage>
      </SetupUILanguage>
      <InputLocale>en-us</InputLocale>
      <SystemLocale>en-us</SystemLocale>
      <UserLocale>en-us</UserLocale>
      </component>
      </settings>
      <settings pass="specialize">
      <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <RegisteredOwner>TestLab</RegisteredOwner>
      <RegisteredOrganization>TestLab</RegisteredOrganization>
      <ProductKey>NPPR9-FWDCX-D2C8J-H872K-2YT43</ProductKey>
      <TimeZone>Eastern Standard Time</TimeZone>
      <AutoLogon>
      <Enabled>true</Enabled>
      <Username>admin</Username>
      <Password>
      <PlainText>true</PlainText>
      <Value>P@ssword</Value>
      </Password>
      <LogonCount>1</LogonCount>
      </AutoLogon>
      <ComputerName>TESTMACHINE</ComputerName>
      </component>
      <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <Identification>
      <JoinWorkgroup>WORKGROUP</JoinWorkgroup>
      </Identification>
      </component>
      <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <RunSynchronous>
      <RunSynchronousCommand wcm:action="add">
      <Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>
      <Description>Setting Network Location</Description>
      <Order>1</Order>
      <WillReboot>OnRequest</WillReboot>
      </RunSynchronousCommand>
      <RunSynchronousCommand wcm:action="add">
      <Path>reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v EnableFirstLogonAnimation /d 0 /t REG_DWORD /f</Path>
      <Description>Hide First Logon Animation</Description>
      <Order>2</Order>
      </RunSynchronousCommand>
      <RunSynchronousCommand wcm:action="add">
      <Path>reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" /v EnableFirstLogonAnimation /d 0 /t REG_DWORD /f</Path>
      <Description>Hide First Logon Animation</Description>
      <Order>3</Order>
      </RunSynchronousCommand>
      </RunSynchronous>
      </component>
      </settings>
      <settings pass="oobeSystem">
      <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <OOBE>
      <HideEULAPage>true</HideEULAPage>
      <NetworkLocation>Work</NetworkLocation>
      <SkipMachineOOBE>false</SkipMachineOOBE>
      <SkipUserOOBE>false</SkipUserOOBE>
      <ProtectYourPC>3</ProtectYourPC>
      </OOBE>
      <UserAccounts>
      <LocalAccounts>
      <LocalAccount wcm:action="add">
      <Name>admin</Name>
      <Group>Administrators</Group>
      <Password>
      <Value>P@ssword</Value>
      <PlainText>true</PlainText>
      </Password>
      </LocalAccount>
      </LocalAccounts>
      </UserAccounts>
      </component>
      <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <InputLocale>en-us</InputLocale>
      <SystemLocale>en-us</SystemLocale>
      <UILanguage>en-us</UILanguage>
      <UserLocale>en-us</UserLocale>
      </component>
      </settings>
      </unattend>
  • I was actually able to finally get this to work today by adding the following to my answer file -

    <Path>sc config wuauserv start= disabled</Path>

    Basically just disabling the Windows Update service completely. With that line, the Upgrade Assistant no longer comes up on login, and then I just add a postinstall task to turn it back on later. Not the optimal solution but it works.
Please log in to comment

There are no answers at this time
Answer this question or Comment on this question for clarity

Answers