/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


msi system context error

05/24/2020 367 views

there is no problem installing msi with administrator privileges. when installing in the context of the system, the installation fails. help me please

msi and log file here:

https://drive.google.com/drive/folders/1OB7HpgKlzR8oA2_5_FrV7mTNTLbHTTOc?usp=sharing

0 Comments   [ + ] Show comments

Comments



Community Chosen Answer

1

Having a 5 second arm chair look. It looks like you're using a shoddy CustomAction that is borking the installer.

Did you even look at your own logs?

MSI (s) (0C:A0) [09:40:07:815]: Doing action: _Set_Deferred_PropsAction 9:40:07: _Set_Deferred_Props. Action start 9:40:07: _Set_Deferred_Props.MSI (s) (0C:18) [09:40:07:837]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI46C7.tmp, Entrypoint: f7InstallShield 9:40:07: Running InstallScript function f7InstallShield 9:40:07: Opening stream of file C:\WINDOWS\Installer\MSI46C7.tmpInstallShield 9:40:07: Extracting support file IsConfig.ini to C:\WINDOWS\TEMP\{79148C41-DC50-497A-B925-543E6A3C02A0}\IsConfig.iniInstallShield 9:40:07: Extracted isconfig.ini to C:\WINDOWS\TEMP\{79148C41-DC50-497A-B925-543E6A3C02A0}\IsConfig.iniInstallShield 9:40:07: Got '{F0BFB3E2-3A15-4533-B4A4-3BB932A17323}' for TempPathGuid from isconfig.iniInstallShield 9:40:07: Attempting to use temp path 'C:\WINDOWS\TEMP\{F0BFB3E2-3A15-4533-B4A4-3BB932A17323}'InstallShield 9:40:07: Using temp folder C:\WINDOWS\TEMP\{79148C41-DC50-497A-B925-543E6A3C02A0}InstallShield 9:40:07: Installing engine...InstallShield 9:40:07: Using product language 1033InstallShield 9:40:07: Extracting support file setup.inx to C:\WINDOWS\TEMP\{79148C41-DC50-497A-B925-543E6A3C02A0}\setup.inxInstallShield 9:40:07: Extracting support file ISRT.dll to C:\WINDOWS\TEMP\{79148C41-DC50-497A-B925-543E6A3C02A0}\ISRT.dllInstallShield 9:40:07: Detected X64 OSInstallShield 9:40:07: Extracting support file ISBEWX64.exe to C:\WINDOWS\TEMP\{79148C41-DC50-497A-B925-543E6A3C02A0}\ISBEW64.exeInstallShield 9:40:07: Extracting support file _isres_0x0409.dll to C:\WINDOWS\TEMP\{79148C41-DC50-497A-B925-543E6A3C02A0}\_isres_0x0409.dllInstallShield 9:40:07: Extracting support file String1033.txt to C:\WINDOWS\TEMP\{79148C41-DC50-497A-B925-543E6A3C02A0}\String1033.txtInstallShield 9:40:07: Skipping optional support file _isuser_0x0409.dllInstallShield 9:40:07: Setting script cmdline...InstallShield 9:40:07: ProductCode is {02A5802D-5CE5-4C1C-B4B1-ABC7CD177C40}InstallShield 9:40:07: Initializing EngineCustomAction _Set_Deferred_Props returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)Action ended 9:40:09: _Set_Deferred_Props. Return value 3.


Anyway, have a look at your CustomAction. My guess is your trying to do something with a CustomAction which you cant as SYSTEM.  Remember when running as SYSTEM, you dont have access to everything, some environmental variables are missing. 

It would help if could enable logging within the CA, but that is not always possible.


The take away at this point is the CA borked with exit code 3. So you need to find out what exit code means.

Answered 05/25/2020 by: rileyz
Red Belt

  • how to fix it?

All Answers

0

Exit code 3 suggests "Path not found".

As for logging CAs, if they're home-baked, they should be using a log of their own, outside of the WI log but that's just my usual paranoia.

Answered 05/26/2020 by: VBScab
Red Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ