/bundles/itninjaweb/img/Breadcrumb_cap_w.png
I recently set up a WDS virtual machine on a Linux host and am receiving the following error message: PXE-E53 no boot filename received. The WDS role is on Windows Server 2016 with the DHCP role installed. The DHCP role is only configured for PXE boot as we have DHCP being managed through our switchstack. DHCP port 60 is set to PXEClient, port 66 is set to to IP address of the WDS server, and port 67 is the path to the wdsnbp.com boot file. I have made sure that the file perms to the boot file are correct as well. I also made sure to open the ports in the firewall. I've also added all the appropriate drivers to the boot image. Can someone help me out here because I really don't know what I'm missing?

Thanks.
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Answer this question or Comment on this question for clarity

Answers

2
Hi,
first off, MS does not recommend using the various DHCP options for PXE as it is not supported, rather use IP-Helpers... however there are situations where this is not possible (in our organisation we also use the various custom options). You use the term "Port" but I assume you mean DHCP options...

I would suggest that you use DHCP Policy objects. This way you create custom vendor classes to deal with the various types of PXE requests (BIOS, UEFI x86, x64 etc.)

An example (although for SCCM will / should also work for you) is here on how to create them.

If you need more info, a suggest searching for "Custom Vendor Classes PXE boot"

Cheers

Phil

Answered 03/10/2018 by: Pressanykey
Red Belt

  • Phil,
    Thank you for the response. You've definitely put me on the right track. We're using a stack of Juniper EX-4200 switches here for our network and they're used for DHCP. I tried adding an IP helper to the config, but it still doesn't seem to be working. At this point I'm not sure what to do. I'm going to be re-imaging about 6 computers very shortly and could really use the WDS server for this.
Please log in to comment