/build/static/layout/Breadcrumb_cap_w.png
Building a package for SCCM, Platform LSF is a prerequisite for the SAS 9.4 install. I've created an mst file with CLUSTERADMIN= %USERDOMAIN%\%USERNAME% , DISWINFIREWALL=Y , HOSTDOMAIN, MASTERLIST OF THE GRIDSERVERS, SERVERHOSTS , CLUSTERNAME , SHAREDDIRINPUT, but testing this package returns a failure of error 1603. Looking in the event viewer on the test PC  Product: Platform LSF 8.0.1 - This setup requires Administrator privileges. Any ideas?
1 Comment   [ + ] Show comment

Comments

  • 1. Are you running your tests manually such as from a CMD line window on that test PC?
    If so, have you elevated the CMD window? (right click CMD > Run as Administrator) and then run your installation string (msiexec /i "%MSI% Transforms="%MST%" /qb) string to test the installation process
    • Yes tested with a batch file and with elevated cmd. and with SCCM package. msiexec.exe /i lsf8.0.1_win-x64.msi TRANSFORMS=lsf8.0.1_win-x64.mst /qn


Community Chosen Answer

1
You need to reconfigure the feature tree so that the user profile-targeted component gets self-healed when the relevant advertised entry-point  - normally an advertised shortcut - is used. The deployment can them be run as normal, using the System account and your user-level stuff gets taken care of by self-healing. . Search ITNinja for "self-healing". 
Answered 05/15/2018 by: VBScab
Red Belt

  • This was deployed successfully with ITCM, we are moving back to SCCM, and currently building the packages for SCCM
    • After a gazillion years doing this nonsense, I can tell you that if you're installing as System and your package contains user profile-targeted components, you're going to have to either tweak the feature tree or go the "I Like Spectacular Fudging Solutions" route and do mental things with scripting to get the logged-in user's username, etc., etc.

      Your call.

All Answers

0
The 'requires admin privileges' message suggests you're using SCCM to deliver the package but having the user interact with the install so you're using the users permission to the PC, which probably isn't a local admin.  You'll want to change it from a 'Per User'  to a 'Per Machine' install.

But when you do that, there might also be a problem with the CLUSTERADMIN property.  To avoid the user permission error (above), you'll want it to be using Per Machine for the install, but the variable stipulated in the CLUSERADMIN property might not be available for the humans that use the computer - unless you grant all users permission to %USERDOMAIN%\%USERNAME%, whatever it might be.
Answered 05/14/2018 by: vjaneczko
Eighth Degree Black Belt