/build/static/layout/Breadcrumb_cap_w.png

Virtualization Question


services not showing after install app-v app

03/14/2014 2661 views

there are two services in app-v application. after launch shortcut serivices not showing from VE. but process is running from taskmgr, service related reg files also showing. I used services.msc / taskmgr form "sfttray /exe cmd "Shortcut_Name"". It gives us another cmd prompt where we can open the taskmgr / services.msc of the VE.

anybody help me, why service not whowing in service.msc ?

 

0 Comments   [ + ] Show comments

Comments


All Answers

0

If services.msc produces a UAC prompt, it will get launched outside of the VE. You have two choices:

1: Use the 'sc query' command instead

2: Type the following command in the virtualised cmd.exe running services.msc to prevent the UAC prompt and therefore ensure it gets launched inside the bubble:

set __compat_layer=runasinvoker

(Please note there are two underscores at the beginning there)

The same issue affects regedit as described here in my blog, I suggest you have a read around the site for more useful App-V tips: http://packageology.com/2012/05/__compat_layer-troubleshooting-app-v-regedit/

Answered 03/17/2014 by: packageologist
Orange Senior Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ