/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


System Image Deployment failing for Windows 10 2004

09/14/2020 378 views

Have 2 System Image Deployments:

Win 10 1909 - Deployment is successful

Win 10 2004 - Deployment fails

Both using the same Pre and Mid level tasks.

Pre Task 

DISKPART Script

select disk 0

clean

convert gpt

create partition efi size=100

format quick fs=fat32 label="System"

assign letter="S"

create partition msr size=16

create partition primary

shrink minimum=500

format quick fs=ntfs label="Windows"

assign letter="C"

create partition primary

format quick fs=ntfs label="Recovery tools"

assign letter="R"

set id="de94bba4-06d1-4d40-a16a-bfd50179d6ac"

gpt attributes=0x8000000000000001


Mid Task 

Apply UEFI Partitions (Recovery Partition)

BAT script

bcdedit /set {bootmgr} device partition=s:

bcdedit /set {memdiag} device partition=s:

bcdedit /set {default} device partition=c:

bcdedit /set {default} osdevice partition=c:

Bcdedit /set {FWbootmgr} displayorder {Bootmgr} /addfirst


I know Win 10 2004 has changed the placement of the recovery partition not sure if that's what's giving me the issue

AOmAl27JeKjpAAAAAElFTkSuQmCC

1 Comment   [ + ] Show comment

Comments

  • Same issue here. We ended up (for testing) duplicating the Apply UEFI mid-task, and added "bcdboot C:\windows /s S:" at the beginning.
    This seems to work, as we get no errors and the image works as it should.
    • Yep I can confirm this worked.

Be the first to answer this question

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ