UEFI Partitions Deployment Issue.

Good Day,

My name is Mathew Duck, and I work IT support for a midsize company. We are currently looking to deploy 30 computers, with pretty much the same configuration. I am currently in the process of creating a 'golden image', and running into an issue with image deployment. We are on the latest version of K2000 (3.6.98680).

I start with a HP 800 G1 SFF computer. The computer is designed for Windows 8, but we have purchased downgrades to 7 Enterprise. I insert a Windows 7 Enterprise install disk, and boot to it. I then delete the two pre-installed partitions, and install Windows. Once Windows has been installed, I go about installing drivers and other software we wish to have on the computers. It is at this point I wish to capture this computer. KACE best practices recommend having a non-sysprepped image on file, in case something goes wrong in the sysprep process. I restart the computer, and pxeboot into an k2000 interface. In order to capture the 100mb EFI partition, I have to run a command prompt in the k2000 interface, and assign the drive a letter name (in this case, S). Once this is done, I capture the 'S' drive and the 'C' drive. The capture process goes well and completes.

It is at this time I start running into problems. I set 1 pre-installation and 1 post installation task in k2000 for the image. My pre-install task is named "Create UEFI partitions" and is as follows:
Select disk  0
Convert gpt
Create partition efi size=200
Assign letter=s
Format quick fs=FAT32
Create partition msr size=128
Create partition primary
Assign letter=c
Format quick fs=NTFS

My post installation task is named "Apply UEFI partitions" and is as follows:
bcdedit /set {bootmgr} device partition=s:
bcdedit /set {memdiag} device partition=s:
bcdedit /set {default} device partition=c:
bcdedit /set {default} osdevice partition=c:
Bcdedit /set {FWbootmgr} displayorder {Bootmgr} /addfirst

When I go to deploy the image to another computer, I get an error at "Apply UEFI partitions":
Task ID: 18
Task Name: Apply Uefi Partitions
Return Code: 1
Error Description: Unknown.

This is driving me crazy! Our older images deploy fine, but they are using 2 different pre and post installation tasks. Our old images use "Windows 7 - Create two Partitions (3.1)”:
select volume 0
remove all noerr
select disk 0
create partition primary size=100
assign letter="C"
create partition primary
assign letter="D"

And "Windows 7 - Format Disks (3.1):
format /q /y /fs:ntfs /v:Windows C:
bootsect.exe /NT60 C:
format /q /y /fs:ntfs /v:System D:
bootsect.exe /NT60 D:

The images we deploy with these pre-installation tasks work. Instead of having a 100mb EFI partition (like my new image), they have 200mb NTFS partitions. Is there a way I can make my new image not use the EFI partition? Is there a setting I missed when installing 7 that would allow me to not use UEFI?

I have been struggling with this issue for about a week now, and would welcome any help or suggestions. I have a ticket into dell, but have not heard back from them. I am not opposed to rebuilding my image, if it can be successfully deployed to another machine.

Thank you for your time, and any ideas you may have.

9 Comments   [ + ] Show comments
  • What is 'Create partition msr size=128' used for in your situation? - cserrins 6 years ago
  • I'm not quite sure. These two tasks have been in our k2000 since my arrival at the company. They are also detailed in this document: http://www.kace.com/support/resources/kb/solutiondetail?sol=SOL113970#sthash.3OIkD6bA.dpuf
    It is my understanding that this piece is necessary to the the booting of a UEFI system? http://en.wikipedia.org/wiki/Microsoft_Reserved_Partition - Mduck 6 years ago
  • We use the same exact pre and post install tasks as you. I have noticed that sometimes during UEFI deployments that the post install task of applying the UEFI partitions will throw errors for each line, but when the computer reboots all is fine. Does your image boot up at all after deploying? - nheyne 6 years ago
  • If my memory serves me correctly, I would either get a broken Windows screen (wanting me to insert a Windows 7 disc), or a "GPT- Formatted Disc, Legacy boot not supported. Press any key to reboot". I at first thought this was an issue with secure boot (or something similar), however, when I go into the machine's 'setup (biosish)' screen, there is no UEFI tab. I have a UEFI 'browser' in my options menu before the f10 setup screen, but it only lets me navigate the UEFI boot partition. There seems to be no options regarding UEFI/BIOS selection. - Mduck 6 years ago
  • I have a system currently sitting at an error, let me test it quick. - Mduck 6 years ago
  • I get a "Windows failed to start. A recent hardware or software change might be the cause. To fix this problem:
    1. Insert your Windows installation disc and restart your computer.
    2.Choose your language settings, and then click "Next".
    3. Click "Repair your Computer"

    If you do not have this disc, contact your system administrator or computer manufacturer for assistance.

    Status: 0xc0000225
    Info: The boot selection failed because a required device is inaccessible."

    After hitting enter here, I get:

    "GPT- formatted disk. Legacy boot not supported. Press any key to reboot. - Mduck 6 years ago
    • Yeah it sounds like your BIOS is set to Legacy boot instead of UEFI. - nheyne 6 years ago
  • Thank you cserrins and nheyne for your attention. What would be the best way to go about changing this BIOS setting? I entered my 'Hewlett-Packard Setup Utility' (BIOS) and selected 'Storage'. Here, I went to boot options, and disabled all the devices under 'Legacy Boot Sources'. I now only see 'UEFI Boot Sources', with 'USB Floppy/CD', 'USB Hard Drive', 'ATAPI CD/DVD Drive', and 'WDC WD5000AAKX-60UGAA0'. I save changes and exit.

    When the computer reboots, I get a 'Windows failed to start' message again, identical to the one previously experienced. When I hit enter this time, I get a message:

    'No option to boot to.'

    Now, while i was in the BIOS menu, I saw a setting under the Security tab named 'Secure Boot Configuration'. Here, there are a few options.

    'Legacy Support: Enabled
    Secure Boot: Disabled
    Key Management
    Clear Secure Boot Keys: Dont' Clear
    Key Ownership: HP Keys
    Fast Boot: Disabled'

    I disabled Legacy Support, when I did, a red messaged popped saying "Changing this option affects Legacy Boot Sources and Option ROM launch policies." Ok is the only answer. I then enabled Secure boot, and accepted my settings.

    Once restarted, the Machine displays "Secure Boot Violation. Invalid signature detected. Check Secure Boot Policy in Setup."

    Any thoughts? - Mduck 6 years ago
    • Can you leave Secure Boot disabled? - nheyne 6 years ago
  • Is there any reason to use uefi when creating and deploying windows 7 images?

    I leave uefi for windows 8. If im using windows 7, i revert the bios back to legacy. I know win7 supports uefi but i see no reason to use it if i have the choice. If anyone else can fill me in that would be great (i dont want to miss out on some cool feature). - david.pegler 6 years ago
  • Hello All. I was finally able to move forward in my imaging process. I disabled all my UEFI boot devices, and imaged with BIOS. This allowed me to use our company's standard imaging/deployment practices. After some harassing, Dell did finally share some information with me:
    you are correct, in order to PXE Boot a UEFI system, you would need to use the KBE on USB process, detailed on page 94 of the below K2000 admin


    Pages 69 and 77 of the above guide cover the capture and deployment of UEFI partitions, and the below KB Article contains screen captures that provide a bit more detail about application of UEFI partitions:


    This was after I had mentioned that I had read that a UEFI image could only be captured using a USB pre-boot environment. I am currently in the process of deploying the 30 computers, but I plan to return to this issue when I am finished. I wish Dell would have given me this information right away. Thanks for all of your input! - Mduck 6 years ago

Answers (0)

Be the first to answer this question

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login


This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ