UEFI PXE Boot does not work - PXE-E18 error Response Timeout


At the moment I'm trying to set up the PXE boot via UEFI. The problem is that we still have computers that have to be installed via legacy. Therefore, I had the manufacturer classes and DHCP guidelines set up according to the instructions from Quest. Booting through legacy works but UEFI does not work. The SDA records that a request arrives.

I get the following display on the computer:
>> Checking Media Presence
>> Media Present
>> Start PXE over IPv4 on MAC: xx-xx-xx-xx-xx-xx

Server IP address is xxx.xxx.xxx.xxx
NBP filename is ipxe.efi
NBP filesize is 0 bytes
PXE-E18: Server response timeout.

What irritates me is the file size of 0 bytes. Does anyone know if that's correct?

0 Comments   [ + ] Show comments

Answers (2)

Answer Summary:
Posted by: Channeler 1 year ago
Red Belt

Hi the ipxe.efi File size is around 915KB.

It sounds like Wireshark is needed here... 

Is the test device on the same subnet as the KACE SDA?
e.g KACE IP is  
Device IP is

Just trying to reduce the amount of devices in between those two.

Do you know if Spanning Tree\PortFast is enabled in your switches?
If connected to a Cisco switch make sure 'spanning-tree portfast' is enabled on the switch. Otherwise iPXE will fail establishing network connection.

What is the brand and model of that test device?
NOT all devices are iPXE compatible out of the box, make sure the latest BIOS is in place.
Secure Boot Disabled.

What is the DHCP you are using?

Are you sure all vendor classes and policies are OK? All the settings are case sensitive.... 

  • The devices are in different subnets and there is no chance to put a testclient in the server subnet (the networkadmins rises their forks when i asked for it).

    We use Extreme switches and we don´t use spanning tree.

    The devices are Dell Optiplex 3020 to 3060. I updated the bios to the latest version but no success.

    We use Windows Server 2012 R2 as DHCP Server.

    The vender classes and polices are fine. We used the guide from the Quest Knowledgebase and i checked every setting several times. - CarstenBuscher 1 year ago
    • You might want to enable spanning tree and try again.
      Or proceed to do a Wireshark analysis.

      Unfortunately if you can't perform an integrity test, by trying to pxe from a client on the same subnet as the SDA, there is no easiest way to rule out the SDA as culprit.

      Unfortunately something is preventing the file from being properly transferred.

      Make sure port 69 is open.

      And prepare for a pcap analisys. - Channeler 1 year ago
    • Also those two are very similar chipsets, Do you have any other device to try? Like Optiplex 7050 or an xps? - Channeler 1 year ago
Posted by: CarstenBuscher 1 year ago
Orange Belt

Top Answer

So... i have found a networkadmin which looks unbusy and i grabbed him. We traced the network communication and found that there are ports which are not listed in https://support.quest.com/kb/129799/network-ports-needed-for-the-kace-systems-deployment-appliance-sda- . We granted access to the range 1024 to 24000 and now the KBE is loaded with UEFI.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login


This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ