/build/static/layout/Breadcrumb_cap_w.png

Server Management Question


Windows activation wizard will not generate an installatin id

02/14/2013 3128 views

I am having a strange issue on my Windows Server. I am using Windows Server 08 Enterprise and after several years of use I am getting the prompt to activate my Windows. I run the activation wizard and choose to use the automated phone system (because I am on a private network) and everytime the wizard will not generate an Installation ID for me to give the automated system. I have attempted to "change the product key" by re-entering my license key in hopes that it will clear this issue up. Is there a way to force the system to generate an Installation ID maybe in the command prompt. I would really hate to have to re-install Windows to fix this issue; this server is a Domain Controller and this would most likely cause my severe headaches to have to seize the roles, demote the DC, re-install windows, promote the server, re-join, re-gain the roles.....you see what I'm getting at here. There has to be a way to force the system to generate an Installation ID via command prompt. Any help would be greatly appreciated. I still have about 46 more days until I have to activate Windows so I have a little time to troubleshoot.

Answer Summary:
0 Comments   [ + ] Show comments

Comments



Community Chosen Answer

1

have you tried to enter the key and activate from the CL with

C:\Windows\System32\slmgr.vbs -ipk <product key> installs the product key but does not activate the server.

C:\Windows\System32\slmgr.vbs -ato

http://technet.microsoft.com/en-us/library/ff793433.aspx

 

Answered 02/14/2013 by: SMal.tmcc
Red Belt

  • I ran the the command slmgr.vbs -ipk <product id> and got the following message "Windows Script Host" Run slui.exe 0x2a 0x8007000D to display the error text. Error: 0x8007000D
    • http://support.microsoft.com/kb/2230957
      • I have read the suggested fix in this KB and made sure that my registry permissions are set accordingly. The permissions are correct and I am still experiencing this issue.
  • Since it is a DC you may have to temp demote and then activate the license at that time then make it a DC again
    • I transferred the operations master roles from this dc to a secondary dc; I have run dcpromo and demoted the problem dc. I removed the AD DS role form the now server; I attempted to run the command slmgr.vbs -ipk <product id> and got the following message again: "Windows Script Host" Run slui.exe 0x2a 0x8007000D to display the error text. Error: 0x8007000D: "The data is invalid". I have tried to follow the guidance in KB 2230957 and I verifed the registry permissions for the SYSTEM account (full controll / with enumerate subkeys). I have run the sfc /scannow and got the message that Windows Resource Protection found corrupt files but was not able to fix some of them. Can I run the Windows Repair Install for this problem? If I do will I have to re-install the OS? Id rather not have to rebuild this server.

All Answers

0

I wound up reformatting this server. After reloading the OS, everything was acting normal and I was able to activate windows.

Answered 03/12/2013 by: Galvatron8
Yellow Belt

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ