/build/static/layout/Breadcrumb_cap_w.png

Wrap Installshield installer w/WIWW - path in silent install switch

Hi,

I currently have an program I am trying to push via GPO onto select computers. The program uses an InstallShield installer and does not create an msi in any of the temp directories. After reading on AppDeploy the correct switches, I currently have it working to install/uninstall correctly via commandline. First I created the two .iss files with:


setup.exe -f1.\install.iss -r
setup.exe -f1.\uninstall.iss -r


While going through the install and uninstall procedures. Afterwards I have tested the process of installing/uninstalling silently with:


setup.exe -f1.\install.iss -s
setup.exe -f1.\uninstall.iss -s


Without the .\ it does not seem to find the file and returns the ResultCode=-5 in the log, as such I added it. I am not inserting a space between the /f1 and the .\install.iss.

This seems to work fine. I was hoping to be able to use WIWW to set those as both actions. I created the MSI
and added the command from the SourceDir and the parameters -f1.\install.iss -s. The install never seems to find the file although it states it completes. I am guessing it is having troubles with the path as I cannot seem to get a logfile from the InstallShield installer if I specify that path either. I have tried the following:
"-f1.\install.iss -s"
-f1.\install.iss -s
-f1install.iss -s
"-f1c:\install.iss -s"
"-f1./install.iss -s"
-f1./install.iss -s

And similar variations... Everytime I try to install it with the created .msi it does not appear to process that file. My .msi is copied to %temp% when I open it, but none of the other files (setup.exe, install.iss, uninstall.iss). I suspect this is how WWIW functions although I am looking at it through Orca and trying to figure out if I need to change the entries. The CustomAction Table is as follows:


WIWW_InstallCommand1 51 InstallAction [SourceDir]CoWriter SE US.exe
WIWW_InstallParam1 3186 InstallAction -f1.\install.iss -s
WIWW_UnInstallCommand1 51 UnInstallAction [SourceDir]CoWriter SE US.exe
WIWW_UnInstallParam1 3186 UnInstallAction -f1.\uninstall.iss -s


At this point I am fairly stuck. I have been going through the forums/website/google/etc without any success.

Any help would be much appreciated.


- Praeses

Edit: Gosh.. typos & CustomAction Table


0 Comments   [ + ] Show comments

Answers (2)

Posted by: Praeses 14 years ago
Senior Yellow Belt
0
Thanks guys, sometimes it helps to just have someone lend an ear.

In Orca I took the msi created by WIWW and editted it to as follows:



WIWW_InstallCommand1 51 InstallAction [SourceDir]CoWriter SE US.exe
WIWW_InstallParam1 3186 InstallAction -f1[SourceDir]install.iss -s
WIWW_UnInstallCommand1 51 UnInstallAction [SourceDir]CoWriter SE US.exe
WIWW_UnInstallParam1 3186 UnInstallAction -f1[SourceDir]uninstall.iss -s


It appears to be working. I will be deploying it to a couple sample boxes and if it is indeed successful I will be pushing it to the final ones in the near future. If you don't hear back from me, assume everything is A-OK. In hindsight I am guessing this is a rather trivial matter for most of you guys.

Edit: Typos.. again.
Posted by: nheim 14 years ago
10th Degree Black Belt
0
Hi Prae,
cool one!
This is clearly a good hint for others too.
Regards, Nick
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ