/build/static/layout/Breadcrumb_cap_w.png

Agents not installing on machines via the Kace K1000

Having issues getting agents pushed out to certain windows xp / Windows 7 machines, when I try and push out an agent I get this error which i posted below.  I talked with out Network admin and all those ports it states  could not be open are completely open, i also tried disabled the firewall completely and made sure file and print sharing was on but still no go.  Is anyone els getting these issues and is there something els that needs to be disabled?


"NETWORK/TCP ports not accessible" 

IP Address: 10.20.2.120
  MAC Address: (unknown)
  Host Name (from DNS): 10.20.2.120
  Suspected OS (from scan): unknown
  Action: unknown
  Provisioning Status: failed
  K1000 Agent Installed: No
  Error Category: NETWORK related failure.
 
Error: TCP ports not accessible

Possibly there is no machine at this IP address. Another possibility is that there is a router or firewall blocking the required ports. If Windows Firewall is turned ON, "File and Print Sharing" must be enabled in the Exceptions list of the Firewall Configuration.
 
  Record Created: 2012/04/16 08:50:11
  Record Last Modified: 2012/04/16 08:50:11
 
  Provisioning Log



[04/13/12 08:52:34 AM] Begin provisioning...
[04/13/12 08:52:34 AM] Executing Windows platform provisioning.
[04/13/12 08:52:34 AM] Probing tcp ports for accessibility.
[04/13/12 08:52:36 AM] Port 139 [netbios-ssn] not accessible
[04/13/12 08:52:36 AM] Port 445 [microsoft-ds] open

STEP 1: CONNECT TCP/SSH - FAILED

[04/13/12 08:52:36 AM] End provisioning run.

0 Comments   [ + ] Show comments

Answers (4)

Answer Summary:
Posted by: nshah 8 years ago
Red Belt
3

At times there could be a switch bewteen that maybe blocking that port. What I would try is under the advance provisioning for this schedule, there is a section that says required ports. Try removing 139 and just leave 445. I've seen it work in the past but its a 50/50 shot. 

 

If that doesn't work you can also install the agent via GPO, login script, batch file....etc.  The KBOX is making the attempt but somewhere on your newtork 139 is being blocked. 

Posted by: Aaron Cool 8 years ago
Red Belt
1

You are getting Error Category: NETWORK related failure.   Error: TCP ports not accessible

 

For Windows XP: 

- Turn Off 'Simple File Sharing'

- Enable 'File & Print Sharing' 

- Windows Firewall Exeptions for TCP 139, TCP 445

 

For Windows 7

- Turn UAC off

- Change Advance Sharing Settings Page - Turn on Network Discovery & Turn On File & Printer Sharing

http://www.kace.com/support/resources/kb/article/Troubleshooting-K1000-Agent-Provisioning-for-Windows-7?action=artikel&cat=2&id=1033&artlang=en

 

or Use GPO to deploy agent: 

http://www.kace.com/support/resources/kb/article/Installing-the-KACE-K1000-Agent-Through-Windows-Group-Policy?action=artikel&id=848


Comments:
  • UAC is off, and File and print sharing is enabled, and firewall exceptions have been set to allow i have also tried completely disableing firewall as well. I will try pushing the client via just 445 instead of both - briggsa 8 years ago
    • I also did the same on my computers and same result. I checked the advanced firewall settings and noticed the Netbios is being blocked by the active directory. I contacted the admin group and they can not find wich policy is blocking the net bios. since we have the computers log to active directory, I disabled the domain firewall and it worked. I contacted KACE support but no luck. Any sugestions? - josefino 8 years ago
  • Are your Network Ports on Switches / hubs open for all the required TCP? - Aaron Cool 8 years ago
    • I also contacted the network group and the ports are not blocked. I do not know if active directory blocks port 139 by default, since exploits can be executed if is open - josefino 8 years ago
Posted by: shivangg 2 years ago
White Belt
0
Hi All,

 Found the easy way.
1. winrm services should be started
2  make firewall off
3. run - cmd(admin)- type winrm quickconfig  
    then 2 prompt will come type y
4 then type winrm e winrm/config/listener
5 deploy again from console it will work
 if this does not work open local policy security
gpedit->computer config->windows setting->security setting->security options-->user account control:admin approval mode for builtin administrator account-- should be disabled.
Posted by: shivangg 2 years ago
White Belt
0

1. winrm services should be started

2  make firewall off

3. run - cmd(admin)- type winrm quickconfig  

    then 2 prompt will come type y

4 then type winrm e winrm/config/listener

5 deploy again from console it will work

 if this does not work open local policy security

gpedit->computer config->windows setting->securitysetting->security options-->user account control:admin approval mode forbuiltin administrator account-- should be disabled.

 And user account control:run all administrators in admin approval mode--should be disabled

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ