/build/static/layout/Breadcrumb_cap_w.png
04/23/2019 177 views

I am receiving the following error when PXE booting EFI in VMware. Any input would be much appreciated. 


_unseccessful.hell (Unsupported Option)0) PXE-E23: Client received TFTP error from the server


Thank you.



0 Comments   [ + ] Show comments

Comments


All Answers

0

Make sure the VM has at least 4GB of RAM.

Make sure the NIC adapter type is E1000.

Make sure your DHCP is properly configured to handle UEFI PXE requests:

https://support.quest.com/kace-systems-deployment-appliance/kb/217556/dhcp-configuration-for-bios-and-uefi-pxe

Review the TFTP logs in the KACE SDA, to determine if the KACE SDA is being contacted or not.

Answered 04/25/2019 by: Channeler
Red Belt

  • I'm verifying the DHCP settings again and looking at the logs but so far everything is correct.

    You are able to PXE into the K2000 out of VMware correct?
    • Correct, be aware of:

      https://support.quest.com/kace-systems-deployment-appliance/kb/232911/unable-to-pxe-boot-vmware-vms-to-legacy-ipxe-with-more-than-one-vcpu
      • This is our DHCP config that works for all workstations and work on VMware before we switched to efi. Any ideas?

        # New PXE boot for KACE
        next-server ;
        filename "ipxe.efi";
        option tftp-server-name "";
        option bootfile-name "ipxe.efi";
      • next-server; ??
        And what about the KACE IP?

        See the examples outlined here:

        https://support.quest.com/kace-systems-deployment-appliance/kb/112037/setting-up-non-microsoft-dhcp-server-cisco-solaris-and-others-
  • Channeler,

    Thank you for the response, I have the IPs in the config. That current config works with PXE on anything except through VMware. I am reviewing the link. Thanks again for the help.
    • It looks like a VM configuration issue....

      see:

      https://www.itninja.com/question/pxe-boot-won-t-work-to-vmware-host

      Do you see entries inside the TFTP log being printed when you try to boot?