/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


K1000 Upgrade to 7.1.x E-mail Not Working - Tried Everything

07/06/2017 1408 views
Hey guys, I'm desperate as KACE support doesn't know what's going on and I'm just going around in circles with them.

We used to utilize authenticated mail transport on the KACE queue's.  We pointed to mail.mydomain.com, had a username/password, and used port 25 with no issues.  We upgraded to 7.0 and e-mail stopped sending.  We upgraded to 7.1 per the forums stating that resolved the issue for some folks.  Still nothing.  This is for auto-response e-mails and reports only.  Inbound e-mails work fine and tickets are created without issue...it's the response that's not working.

We then configured Network Settings->Email Configuration and under server we used the IP address of a server which allows relaying anonymously from KACE.  No username/password, but using port 25.  Rebooted appliance.

We then altered the configuration and have tried every combination of IP address/username/password for each queue.  Now all queues are set to IP address of an Exchange server, port 25, no username, no password and that allows e-mail to flow sporadically.  They'll come through for a bit, then stop coming through.  When they don't come through the EXIM log says: R=smart_route T=transport_25 defer (-53): retry time not reached for any host

I'm still getting e-mails from 4 days ago as those clear out slowly. 

Now support wants to get on and verify we have an MX record setup in DNS.  Why? Who knows! MX Records aren't required for sending mail to an IP address for a relay that is anonymous anyway, they're grasping at straws and now I am, too. We're running Exchange 2010 on-prem, no O365 or hybrid at all.
2 Comments   [ + ] Show comments

Comments

This question is locked
  • Hi kbigelow, did you even find a solution to this problem? We are having the exact same issue.
  • Yes, but it requires support depending on how backed up your e-mail system within KACE is:
    1.) Replace Network Settings->SMTP Server with IP address of SMTP Relay; not DNS, not OWA....IP only and port 25.
    2.) Change all queue's to use the same IP address and port 25 and remove any authentication user/pwd.
    3.) Edit your relay in Exchange to allow anonymous. (I know, I know, this sucks...I haven't tested adding authentication back yet but this at least gets you working)
    4.) Call KACE Support; get escalated and they have to go into the SSH tunnel to login to the backend of KACE and try to force send all of the e-mails that are stucked. They basically clog everything up and have to be force cleared.
    • Fantastic, I really appreciate the feedback

Be the first to answer this question

This question is locked
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ