/build/static/layout/Breadcrumb_cap_w.png

K2000 - KBE Manipulator - AutoIt Error Line 8234

I'm trying to run the KBE Manipulator version 3.7.1.2.  I have have the latest Windows 7 AIK installed as well as the latest Dell CLI Utility and K2000 Media Manager.  Every time I try running KBE Manipulator, as a user or administrator, it pops up an error message titled, "AutoIt Error" and states, "Line 8234 (File "C:\Program Files\Dell\Kace\KBE Manipulator\kbe_manipulator_x64.exe"):  Error: Subscript used on non-accessible variable.

I've checked the path it references and it exists, so it must be something else.

Any help would be greatly appreciated.

0 Comments   [ + ] Show comments

Answers (2)

Answer Summary:
Posted by: SMal.tmcc 5 years ago
Red Belt
1
close the kbem
delete the files in your temp directory
open a cmd window and do a net use.
delete any connections to the k2000

Comments:
  • I did what you suggested and still received the same error. I also logged off and back in to free up as many files in the temp directory and cleared them out again; still the same error when running kbe manipulator.

    Any other thoughts? - captains1stm8 5 years ago
    • let me email the author of that - SMal.tmcc 5 years ago
      • Sounds good. Thanks! - captains1stm8 5 years ago
      • he is looking into it, I am seeing if I can duplicate it. can you update your question with screen shots of the settings you have checked - SMal.tmcc 5 years ago
    • also what does the last couple lines of the kbem log that is in your temp directory show? - SMal.tmcc 5 years ago
    • got everything installed you listed on a w7x64 machine and it uploaded without a problem. waiting to see your screen shots and log entry - SMal.tmcc 5 years ago
      • Sorry for the delay. Here are the screenshots:
        http://imgur.com/a/xj6cU

        The log brings about another point that I should make, I work on an isolated network with no outward facing connections. The K2000 also sits on that network. - captains1stm8 5 years ago
      • I think it is the isolated network that is your problem. The KBEM goes and checks for updates when it starts and that is where your logs stop each time. - SMal.tmcc 5 years ago
      • emailing author with that finding to see what he says - SMal.tmcc 5 years ago
      • I am able to duplicate that error by hooking my test machine to another machine so I have a connection between t he 2 that goes no where. It is the network you are on that is causing this error - SMal.tmcc 5 years ago
      • I see through wireshark that it tries hitting scriptingninjas.com, but it's actually waiting for a return so setting it to localhost won't work. Any ideas on a work around, if any? - captains1stm8 5 years ago
      • Heard from Corey, he will work on a fix to bypass this check if the KBEM can not see an outside address. - SMal.tmcc 5 years ago
      • Great! Thanks a lot for helping with this. - captains1stm8 5 years ago
      • I have done a lot of beta testing for the K2 engineer that wrote that app so I know it really good, glad to help. - SMal.tmcc 5 years ago
    • Try unplugging the network and start kbem. See if it gets to first screen, is fo, then plug the network cable back in and you should be good to go.
      -Corey - cserrins 5 years ago
      • Hi, Corey. I just tried that and get the following messages and log data:
        http://imgur.com/a/D8VL4 - captains1stm8 5 years ago
      • To clarify, I get the, "No Active Internet Connection" message first. Once I click OK to that, I get the "KBE Manipulator" window thanking me for using it. Once I click OK to that, it stops. - captains1stm8 5 years ago
      • I've been out of the office for a few days. No other suggestions? I was really hoping to use your tool to setup automatic deployments. Let me know. Thanks again! - captains1stm8 5 years ago
Posted by: cserrins 5 years ago
Red Belt
0

Top Answer

This has been fixed in version 3.7.1.8, which is available on the KBE Manipulator page.
-Corey

Comments:
  • That's great! I'm downloading it now and will report back.

    Thanks! - captains1stm8 5 years ago
  • It works! Thanks a lot for following up on this. - captains1stm8 5 years ago
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ