/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Hello, I have seen where i have upgrade the Kace Agent a few times the AMP.conf gets wiped leaving the contents of the file empty.
This is obviously a problem as it shows the machines as offline in the Kace SMA.
So does anyone know of a better idea than to look at all the machines that are showing as Offline in the SMA and to ping them to actually see if they are online?



1 Comment   [ - ] Hide Comment

Comments

  • If you create a custom inventory rule with this you can keep track of amp.conf content

    ShellCommandTextReturn(cmd /q /c type C:\ProgramData\Quest\KACE\amp.conf)

    but i suggest following c.castellari's workaround

    kbox is hardcoded into the agent as a fallback host if amp.conf is empty or corrupt
Please log in to comment

Answer this question or Comment on this question for clarity

Answers

0
Check the entries on this post:

http://www.itninja.com/question/amp-conf-getting-wiped
Answered 03/01/2018 by: Channeler
Ninth Degree Black Belt

Please log in to comment
0
I have decided to write a .bat file and a task scheduled job to run each day to check the amp.conf file.
Thanks for the link below, it seems im not the only one with this issue.
Answered 03/06/2018 by: markc0
Purple Belt

Please log in to comment
0
A good workaround is creation of a CNAME or A "kbox" record in your DNS, that points directly to your K1000 Appliance.

The agents will connect to "kbox" and will download the right amp.conf :)
Answered 03/15/2018 by: c.castellari
Orange Belt

Please log in to comment